Do you suffix unit test classes with "Tests"?
  v1.0 Posted at 26/04/2018 9:42 AM by Tiago Araujo
Unit test classes should be suffixed with the word "Tests" for better coding readability.

​[TestFixture] public class SqlValidatorReportTest { }

Bad - Unit test class is not suffixed with "Tests"​

[TestFixture] public class HtmlDocumentTests { }  ​

Good - Unit test class is suffixed with "Tests"​

We have a program called SSW Code Auditor to check for this rule.

Related rules

    Do you feel this rule needs an update?

    If you want to be notified when this rule is updated, please enter your email address: