Home
Do you verify that your server meets the minimum requirements?
  v1.0 Posted at 13/08/2015 1:25 AM by Ben Cull

Whenever you upgrade software, it's a good idea to make sure that your system meets the requirements for the newer version. This is particularly important for server applications like Team Foundation Server.

​If you're upgrading from TFS 2013 Update 4 to TFS 2015, there is a small difference in system requirements. Make sure that your system meets the Visual Studio Team Foundation Server 2015 RC system requirements:

Server Supported Operating Systems

  • Windows Server 2008 R2 SP1
  • Windows Server 2012
  • Windows Server 2012 R2
  • Windows Small Business Server 2011

Client Supported Operating Systems

  • Windows 7 Service Pack 1
  • Windows 8.1
  • Windows 8
  • Windows 10 Technical Preview

Hardware Requirements

  • 2.2 GHz or faster processor
  • 1 GB or more RAM
  • 8 GB or more of available hard disk space

​ 

The old TFS 2013 Update 4 requirements are available at the following location: Description of Visual Studio 2013 Update 4.

Related rules

    Do you feel this rule needs an update?

    If you want to be notified when this rule is updated, please enter your email address:

    Comments:

    Note: Social Media login for Yotpo is not working in IE or Safari, please use Chrome. We are waiting for Yotpo to fix it.